找回密码
 注册
查看: 3042|回复: 3

CT-3 not providing proper PD?

[复制链接]

0

主题

4

回帖

24

积分

Member

积分
24
发表于: 03-05-2021 03:12:55
| 显示全部楼层 |阅读模式
Edited by roger2k at 03-05-2021 03:53

Hi,

I try to measure power consumption of various devices: a Thinkpad, of a Google pixel 4a and a Huawei p20 lite.
My power supply offers various 'fixed' voltages via PD, the CT-3 also detects these properly. When I then select 20V and connect 'usb-c out' with the Thinkpad, then the Thinkpad is not loading from the source. I have a second small power meter (satechi), it shows that the 20V are offered properly - but the Thinkpad is not using the power source.
Same for the 2 mobiles: offering 5V, the mobiles are not taking/accepting the power. The functionality to search for available quickcharge protocols does not find anything - but I think that's expected for both phones. But PD should work..
I have an external enclosure for a NVMe module, when connecting that one I properly get the voltage, current etc. displayed.

All ideas welcome..
回复

使用道具 举报

0

主题

4

回帖

24

积分

Member

积分
24
 楼主| 发表于: 04-05-2021 18:36:45
| 显示全部楼层
Hi,

I did some more testing. My power supply offers the following PD3 fixed modes: 5V@3A, 9V@3A, 15V@3A, 20V@3.25A.
Now, when I connect that power supply to the "usb-c in" of the CT-3, then I can on the right side usb-A output use 5V@1.3A (with the google pixel4a as load), or 5V@2A (thinkpad as load). When switching to modes 9V or 20V, no power gets taken.
When I use the "usb-c out" connector of the CT-3, I can get 9V@0.7A with the Google pixel4a as load. But when configuring 5V or 20V, then the Thinkpad does not use these as load.

Questions: the usb-A connector on the right side, does it support 9V or 20V? The "usb-c out" mode, does it support PD3 output with 20V? Has anybody seen these modes in use with the CT-3, or can the vendor comment on whether these modes should be usable?

Thanks.
回复

使用道具 举报

0

主题

4

回帖

24

积分

Member

积分
24
 楼主| 发表于: 04-05-2021 18:49:52
| 显示全部楼层
PS: "usb-c out" and 5V@2A with the Thinkpad as load also works.  Just why not 20V?
回复

使用道具 举报

0

主题

1

回帖

21

积分

Member

积分
21
发表于: 15-03-2023 02:06:57
| 显示全部楼层
TL;DR: Switch PD COM to off, maybe rotate one USB-C plug (on the CT-3)

I have a Thinkpad and test as follows:

Move "PD COM" switch to 'off' position on the CT-3
Plug Lenovo power supply into USB-C IN
Use USB-C to USB-C cable to connect CT-3 to laptop

If it does not work, rotate one USB-C connectors on the CT-3 (pull out, insert 180 degress turned).
USB-C is as USB-A, sometimes, you need to plug in in the right way :-D
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

Archive|手机版|小黑屋|AVHzY Forum

GMT-8, 26-02-2024 03:47 , Processed in 0.087304 sec., 16 queries .

Powered by Discuz! X3.5

© 2001-2023 Discuz! Team.

Release 20231001, © 2001-2024, Tencent Cloud.

MultiLingual version, Rev. 4300, © 2009-2024 codersclub.org

快速回复 返回顶部 返回列表